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What we'll cover today

● Why migrate
● Comparisons

– Word vs. Writer
– Excel vs. Calc
– PowerPoint vs. Impress
– Access vs. Base

● Migration tools
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Why migrate?

● Its open source
● Uses ISO standard file format (ODF)
● Available in over 70 languages
● Cross-platform
● Support available
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Is it cost effective?

● Initial purchase/outlay cost
– Microsoft Office Professional 2003: 

RM1,710
– Corel WordPerfect Office: RM1,097
– IBM Lotus SmartSuite R9.8: RM650
– Sun StarOffice 8: RM278
– OpenOffice.org: Free download

Price list current as of 06/12/2006, via Software Exchange (Malaysia) Sdn Bhd
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Is it cost effective?

● Saves on ongoing licenses and 
upgrades

● Re-training costs similar, if not cheaper
● Changeover support, and support in 

general available from ISVs
● Data/document conversions

– Between Office versions
– From Office to OpenOffice.org (use ODF!)
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What's missing?

● Integrated unabridged dictionary & 
thesaurus

● Grammar checker
● File interoperability & filters
● VBA Macros
● Varied clip-art & templates
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The power of PDF

● All applications have 
the export to PDF 
functionality

● Advanced options 
are available as well
– No printing
– No copying

● No editing
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PDF Forms

● Create forms that can be filled up in a 
standard PDF reader and submitted via 
the Web or printed Filling out details in 

Adobe PDF
Creating a form in 
Writer
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Word vs. Writer

● Styles are how 
OpenOffice.org handles 
management of varying 
formats in the document

● Format Paintbrush
– Was missing, is 

implemented now!

vs.
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Word vs. Writer

● Tables are the same
– Creation via Insert, as opposed to a 

dedicated menu
– Has AutoFormat abilities
– Can be used to enter formulae 

● Fields
– Standard, Extended, and also Data Source 

(i.e. Pull data from a database)

Can also be created via
the toolbar quickly
(Ctrl+F12 is another)
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Word vs. Writer

● Object insertion
– Insert -> Object -> Choose an object

● Word Count
– Fixed via File -> Properties -> Statistics

vs.

Notice count for 
selection!
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Excel vs. Calc

● No more row limitation – 65536 rows!
● Complex statistical functions might be 

unavailable
● Which is correct?

– =IF(C3 > 0, D1+D2, D1-D2)
– =IF(C3 > 0; D1+D2; D1-D2)

This is one of the most common differences that will 
affect you. Take note of the “;” instead of the “,”!

<- Excel

<- Calc
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Excel vs. Calc

● DataPilot (instead of the Pivot Table)
– Can do statistical analysis on data 

independent of the sheet/cells 
(spreadsheet) but also data sources!

In its simplest form, the DataPilot 
in action.

vs.
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Features of confusion

● When apply filters, my totals change?
– SUBTOTAL(range): adjust totals based on 

filter
– TOTAL(range): total that ignores filters

● FIND or SEARCH?
– FIND(search,text): substring, standard text 

match
– SEARCH(search,text): regular expressions 

allowed
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PowerPoint vs. Impress

● Animated sequences, multimedia plug-
in's not Impress's strong points
– Requires Java Media Framework

● Export to Flash, layers, and live data 
sources are

● Limited templates
● Can also create via Writer (styles)

– File -> Send -> AutoAbstract to Presentation
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Access vs. Base

● File incompatibility
● All is not lost

– Use the MySQL Migration Toolkit
– Convert Access to MySQL (locally running, 

or on a server)
– Manipulate data using Base, connecting to 

MySQL

● Benefits are a plenty – web access to 
your DB!
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Access vs. Base

Base displays and 
edits the migrated 
Access database, 
directly to MySQL.

An SQL query to show some 
data from the database.

Updates 
have been 
applied! Its 
instant.
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Migration tools

● SCAI Migration 
Analysis Tools

● Resolvo MoveOver
● File -> Wizards -> 

Document 
Converter AutoPilot
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Everything else you're used to...

is pretty much the same!
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AutoText in Writer

Search & Replace

Formatting

Headers & Footers

Templates

Hyperlinking

Drawing

Math

Bookmarks

Table of 
Contents

Bibliographies

Mail Merge

Revision 
Control

Scenarios

Goal Seek

Notes

Sections

Queries

Forms

Reports
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Resources

OpenMalaysiaBlog - http://www.openmalaysiablog.com/
Interesting opinion pieces on why ODF rocks

OpenOffice.org - http://www.openoffice.org/

For all your support, consultation, forum, list, etc. needs

Planet OpenOffice.org - http://planet.go-ooo.org/ 

Listen to the developers and evangelists speak
OpenMalaysiaBlog - http://www.openmalaysiablog.com/
Interesting opinion pieces on why ODF rocks
OpenOffice.org - http://www.openoffice.org/
For all your support, consultation, forum, list, etc. needs
Planet OpenOffice.org - http://planet.go-ooo.org/ 
Listen to the developers and evangelists speak
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Thank You!

Colin Charles
colin@{mysql.com,arenatechniques.com}
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What we'll cover today

● Why migrate
● Comparisons

– Word vs. Writer
– Excel vs. Calc
– PowerPoint vs. Impress
– Access vs. Base

● Migration tools
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Why migrate?

● Its open source
● Uses ISO standard file format (ODF)
● Available in over 70 languages
● Cross-platform
● Support available
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Is it cost effective?

● Initial purchase/outlay cost
– Microsoft Office Professional 2003: 

RM1,710
– Corel WordPerfect Office: RM1,097
– IBM Lotus SmartSuite R9.8: RM650
– Sun StarOffice 8: RM278
– OpenOffice.org: Free download

Price list current as of 06/12/2006, via Software Exchange (Malaysia) Sdn Bhd

Software Exchange (Malaysia) Sdn Bhd Pricelist
http://www.softwareexchange.com.sg/my/pricelist.pdf 
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Is it cost effective?

● Saves on ongoing licenses and 
upgrades

● Re-training costs similar, if not cheaper
● Changeover support, and support in 

general available from ISVs
● Data/document conversions

– Between Office versions
– From Office to OpenOffice.org (use ODF!)

LXer: The Real Cost of Retraining for OpenOffice.org
http://lxer.com/module/newswire/view/46775/

Support available via: http://support.openoffice.org/index.html
Sun is included in the list of support. 

Support via the international network of consultants: 
http://bizdev.openoffice.org/consultants.html 

It is widely known that Office is not compatible between Office 
versions. 
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What's missing?

● Integrated unabridged dictionary & 
thesaurus

● Grammar checker
● File interoperability & filters
● VBA Macros
● Varied clip-art & templates

Dictionaries/thesaurus are available online, or via tools that connect 
to the online version (just like in Microsoft Office), but these are 
sub-optimal.

Grammar checker is being integrated (October 2006) as it was a 
Google Summer of Code project that turned into success.

File interoperability with MS Office isn't 100%, but no package can 
aim to do so, in theory, not even Office:Mac and Office 2003 for 
instance. File filters like the WordPerfect filter do exist, but are 
not integrated.

VBA Macros aren't touched. The ability to edit them exists. The 
ability to run them to a certain extent exists via Novell's OOo. 
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The power of PDF

● All applications have 
the export to PDF 
functionality

● Advanced options 
are available as well
– No printing
– No copying

● No editing
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PDF Forms

● Create forms that can be filled up in a 
standard PDF reader and submitted via 
the Web or printed Filling out details in 

Adobe PDF
Creating a form in 
Writer
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Word vs. Writer

● Styles are how 
OpenOffice.org handles 
management of varying 
formats in the document

● Format Paintbrush
– Was missing, is 

implemented now!

vs.

Get the Stylist via hitting the F11 key

Format Paintbrush is used to copy a style (manually created) and 
apply it to other parts of the text. 

Format Paintbrush = Format Painter in Word
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Word vs. Writer

● Tables are the same
– Creation via Insert, as opposed to a 

dedicated menu
– Has AutoFormat abilities
– Can be used to enter formulae 

● Fields
– Standard, Extended, and also Data Source 

(i.e. Pull data from a database)

Can also be created via
the toolbar quickly
(Ctrl+F12 is another)
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Word vs. Writer

● Object insertion
– Insert -> Object -> Choose an object

● Word Count
– Fixed via File -> Properties -> Statistics

vs.

Notice count for 
selection!
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Excel vs. Calc

● No more row limitation – 65536 rows!
● Complex statistical functions might be 

unavailable
● Which is correct?

– =IF(C3 > 0, D1+D2, D1-D2)
– =IF(C3 > 0; D1+D2; D1-D2)

This is one of the most common differences that will 
affect you. Take note of the “;” instead of the “,”!

<- Excel

<- Calc

Fun bug: http://qa.openoffice.org/issues/show_bug.cgi?id=18704
The discussion of recent article on Slashdot mentioned that, for all its 

money
and resources, Microsoft has botched the statistical functions in the 

Excel
spreadsheet:

http://www.agresearch.cri.nz/Science/Statistics/exceluse1.htm
http://www.practicalstats.com/Pages/excelstats.html
http://www.cof.orst.edu/net/software/excel/no-stats.php
http://www.npl.co.uk/ssfm/ssfm1/validate/testing/excel.html

If with all their resources they can't do it right, I have to say that I'm
concerned about a package (Calc) put together mostly by volunteer 

programmers
(not statisticians and not numerical analysts, I would presume). This 

is not to
slam those people, but statistics is no place for amateurs, even those 

copying
formulas out of a book.

I would suggest that all statistical functions in Calc be vetted by an
computer-experienced statistician, who will run extensive tests and 

report on
weak areas. All functions, especially the statistical functions, should 

also be
examined by someone experienced in numerical computing. At the 

very, very least,
the developers need to find a large suite of tests to thoroughly 

exercise the code.
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Excel vs. Calc

● DataPilot (instead of the Pivot Table)
– Can do statistical analysis on data 

independent of the sheet/cells 
(spreadsheet) but also data sources!

In its simplest form, the DataPilot 
in action.

vs.
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Features of confusion

● When apply filters, my totals change?
– SUBTOTAL(range): adjust totals based on 

filter
– TOTAL(range): total that ignores filters

● FIND or SEARCH?
– FIND(search,text): substring, standard text 

match
– SEARCH(search,text): regular expressions 

allowed
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PowerPoint vs. Impress

● Animated sequences, multimedia plug-
in's not Impress's strong points
– Requires Java Media Framework

● Export to Flash, layers, and live data 
sources are

● Limited templates
● Can also create via Writer (styles)

– File -> Send -> AutoAbstract to Presentation

Demo this: 
Google for the UN Universal Declaration of Human Rights
Copy/Paste into Writer
Look at the styles
(Notice the use of Heading 4's)
File -> Send -> AutoAbstract to Presentation
Presto, a simple, easy to use presentation created!
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Access vs. Base

● File incompatibility
● All is not lost

– Use the MySQL Migration Toolkit
– Convert Access to MySQL (locally running, 

or on a server)
– Manipulate data using Base, connecting to 

MySQL

● Benefits are a plenty – web access to 
your DB!
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Access vs. Base

● Click to add an outline

Base displays and 
edits the migrated 
Access database, 
directly to MySQL.

An SQL query to show some 
data from the database.

Updates 
have been 
applied! Its 
instant.
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Migration tools

● SCAI Migration 
Analysis Tools

● Resolvo MoveOver
● File -> Wizards -> 

Document 
Converter AutoPilot

SCAI – still dumps to Excel files ! Not really for Office 2000/2003

Resolvo – compatible with very old Linuxes, still OOo 1.1 based
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Everything else you're used to...

is pretty much the same!
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Search & Replace

Formatting

Headers & Footers

Templates

Hyperlinking

Drawing
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Resources

OpenMalaysiaBlog - http://www.openmalaysiablog.com/
Interesting opinion pieces on why ODF rocks

OpenOffice.org - http://www.openoffice.org/

For all your support, consultation, forum, list, etc. needs

Planet OpenOffice.org - http://planet.go-ooo.org/ 

Listen to the developers and evangelists speak
OpenMalaysiaBlog - http://www.openmalaysiablog.com/
Interesting opinion pieces on why ODF rocks
OpenOffice.org - http://www.openoffice.org/
For all your support, consultation, forum, list, etc. needs
Planet OpenOffice.org - http://planet.go-ooo.org/ 
Listen to the developers and evangelists speak
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