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Creative Commons License

Attribution-NonCommercial-ShareAlike 1.0

Attribution

You must give the original author credit.

@ Noncommercial

You may not use this work for commercial purposes, without the explicit permission
of the author.

Share Alike

If you alter, transform, or build upon this work, you may distribute the resulting
work only under a license identical to this one.

[SOITIE RISHTS RESERLIED

http://creativecommons.org/licenses/by-nc-sa/1.0/

Full legal license: http://creativecommons.org/licenses/by-nc-sa/1.0/legalcode

If you would like to use this for commercial purposes, please write to Colin Charles, at
byte@aeon.com.my or at PO BOX 8188, Monash University LPO, Clayton, Victoria, 3168, Australia.
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* You are free:

* to copy, distribute, display, and perform the work
* to make derivative works

And...

For any reuse or distribution, you must make clear to others the
license terms of this work.

* Any of these conditions can be waived if you get permission from the
author.



Agenda and Goals

* Learning about OpenOffice.org
- The project and community
* The Office Suite Applications

- Writer (word processor), Calc
(spreadsheet), Impress (presentation),
Draw (drawing), Web (HTML Editor), Math
(formula editing), Databases, Mail Merge,
and others
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The concept of using Open Source software may not exist with most
of you yet, unless you've been immersed in a Linux platform for
instance. You may think that software you get for free may be inferior
to commercial offerings that you have purchased, but by the end of
all of this, | hope you realize differently.

The current version that you can use is OpenOffice.org 1.1 — get it
from http://www.openoffice.org/

The next target milestone will be 2.0.

Through-out the text, you may see reference to OpenOffice.org as
00o0. 000 has become the accepted “short form” for referring to
OpenOffice.org.

Calling OpenOffice.org “OpenOffice” for instance is not entirely
correct.



Why OpenOffice.org?

* Piracy doesn't:

* Provide bug fixes, rights to steer future
releases, no ability to get support for
stolen software, and no building of local
software industry

* Microsoft has DRM
* Will run on multiple platforms
*Inter-operable with Microsoft Office
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It's free.

Digital Rights Management (DRM) means its illegal to reverse engineer
Microsoft's file format. It also forces updates, and sharing documents
with others becomes more disabled. This is rather unfortunate, but
Microsoft seems to think its the right thing to do.

OpenOffice.org claims that there is a 98% compatibility rate with
Microsoft Office files.

Microsoft, in Office 2003 has aimed to use full XML file format
compatibility (with a few modifications), so this means things may
become more compatible.

Platform support is impressive: Windows, Linux and Solaris are
natively built by Sun themselves. There are Mac OS X ports, FreeBSD,
Linux PPC, and many other platforms are supported as well - thanks
to user defined ports.

KOffice has also decided to utilize the Oasis XML file format — so
Koffice files will be fully inter-operable with OpenOffice.org files.



How it differs from other
packages

e Microsoft Office

- Writer lacks a grammar checker; Calc has a
maximum of 32,000 rows

* StarOffice - Sun's commercial offering

- Front-end database component (AdabasD);
templates & clip-art gallery; a few file
filters; fonts; support
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Writer doesn't have a grammar checker and the feature has been
requested for, but to no avail - we don't expect to see this even in the
2.0 release.

Calc doesn't support more than 32,000 rows, while Excel supports
64,000 rows. Should not be an issue for many.

OpenOffice.org lacks a front-end database feature - there exists
database support if you have a working back-end. AdabasD is a
commercial offering from Sun, but if you're looking for a straight
Microsoft Access replacement, it's not going to be easy at the
moment. OpenOffice.org Base is expected for 2.0.

It lacks many usable templates, clip art, sounds, videos and so on.
There are templates online available for download, at many different
community-based sites.

In comparison to file fiters, OpenOffice.org lacks support for
importing WordPerfect 5.1 files, which StarOffice has. Work is being
done to get imports working however, and there exists a 3rd-party
application to get it working.

StarOffice includes Asian language fonts by default, that
OpenOffice.org lacks.

Support - commercial based support exists, but not by Sun (or in
Office's case, Microsoft). There are other organizations, user groups,
and so on that offer support.



Licensing

e Dual-licensed
- GNU Lesser General Public License (LGPL)

- Sun Industry Standards Source License
(SISSL)

e Allows for unlimited commercial use

* Copying and redistribution is
encouraged

* No more worrying about “piracy”
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For more information on the LGPL and the SISSL, the Open Source
Initiative have some fairly useful resources — mainly the terse legal
documents to read: LGPL (
http://www.opensource.org/licenses/lgpl-license.php); SISSL (
http://www.opensource.org/licenses/sissipl.php)

Commercial use is allowed on any number of workstations on any
number of platforms - the Office suite is completely 100% free.
Remembering that the SISSL allows proprietary use of the code,
commercial use and distribution on CDROM's or even packaged
products are welcome.

Commercial distribution is allowed too, and there are several
companies selling them. You are however encouraged to follow the
CDROM ISO standard that OpenOffice.org sets for you, and are
encouraged to register with the Distribution project -
http://distribution.openoffice.org/

There is never a pirated copy of OpenOffice.org!



Where do | get help?

* http://www.mackmoon.com/OOoHelpOutline.html
* http://www.oooforum.org/

* http://ooodocs.sf.net/

* http://ooextras.sf.net/

* Mailing lists on openoffice.org

* OpenOffice.org 1.0 Resource Kit

* 0OOoSwitch: 501 Things You Wanted to Know About
Switching to OpenOffice.org from Microsoft Office
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OpenOffice.org Unofficial FAQ:
http://www.bytebot.net/openoffice/faq.html

OpenOffice.org Documentation project:
http://documentation.openoffice.org/

OOoMacros (for macro specific help): http://ooomacros.org/

For Mailing Lists:

announce@openoffice.org - for announcements
users@openoffice.org - for questions that users have - high volume,
you may want the digest version

discuss@openoffice.org - for discussions relating to OpenOffice.org
and the development - high volume, digest version exists

There are plenty of others:
http://www.openoffice.org/ml_guidelines.htmi

With regards to Books:

Commercial material like the OpenOffice.org Resource Kit (
http://www.getopenoffice.org/), or the Taming OpenOffice.org Writer
(http://www.taming-openoffice-org.com/), or even the OOoSwitch
book (http://www.hentzenwerke.com/catalogpricelists/000501.htm)
come in handy.

There are ClueSheets (http://www.cluesheets.com/) which are great
to get you up to speed quickly.



Niggling Linux Issues...

* KDE might be preferred to, in
comparison to GNOME

- Lack of inter-application cut & paste
* Red Hat/Mandrake — use RPM's
* Debian - use apt-get

* Or just get the officially built tar-balls
from the website
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Exercise: Install OpenOffice.org on your machine.

Red Hat Linux / Fedora / Mandrake Linux
* Get your CD's, and use the appropriate package manager.
* Otherwise at a console, do:

rpm -ivh <filename.rom>

Debian

* Packages required include: openoffice.org-bin, myspell-en-gb/us (a
dictionary), openoffice.org-debian-files (extra Debian specific files),
openoffice.org-gnome (GNOME desktop integration), openoffice.org-
help-en (help files), openoffice.org-hyphenation-en-gb/us
(hyphenation patterns)

* If tracking the “stable” branch of Debian, the mirror's list will help:
http://openoffice.debian.net/mirrors.html (if tracking “unstable”, it is
included).

Tar-balls

* ¢p OO0 * Linuxintef.tar.gz ~/

* tar -zxvpf OOo_*LinuxIntel*.tar.gz

* cd OOo<TAB>

* ./setup (or ./setup -net if you're configuring it for a multi-user
environment)



Common Features

* The entire application shares common
features:

- AutoCorrect

- Spell Check

- Thesaurus

- Help

- PDF Exporter

- Stylist/Navigator
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Exercise: Start OpenOffice.org. Play around with Writer.

* AutoCorrect — Tools -> AutoCorrect. Choices for Replacements, and
Exceptions, the latter being particularly useful for adding thing's like
“O00” or “CDs"”, so the AutoCorrect doesn't automatically correct it
to something else.

* Changing a (C) to become a © is what the AutoCorrect also handles;
also for common mis-spellings like “teh” as “the”.

* Tools -> Spell Check -> Check. The AutoSpelicheck option can also be
selected, so the red-wiggly lines are displayed at the bottom of
incorrectly spelled words.

* Tools -> Thesaurus - highlight a word first, then select the option. A
pop-up dialog will offer replacements from the thesaurus.

* Help, the PDF Export capability, as well as the Stylist and Navigator
features are more in-depth topics which we will go into later.



Online Help

Options

\v OpenOffice.org Help - Help about OpenOffice.org Impress.

[Help about OpenOfiice.org Impress

Contents Index | Find | Bookmarks |

Search term

[date fields form

Sl=IE
alesra e
seconds are increased or decreased step by step.
Field

overview
data values
data view
data sources
date fields

properiies.
date formats
dates

- beginning 01.01.1900
beginning 01/01/1904
default
fixed

languages
printing in presentations

Sub-
topics

variable
dBase
database settings.
deleted records
dBase database
DDE

definition
deactivating
plug-ins
decimal places
numbers
[decimal tab stops

erting
decimal tabulator

™|

Display

423 Use this iconto create a numerical field. f the form s linked 10 a database, the
numerical values in the form can be adopted from the database.
Formatted Field

4 Click this icon to create a formatted field. That is, a text box where you can
define how the inputs and outputs are formatied and which limiting values apply.

A formatied field has special control properties (choose Format - Control)

Currency Field

L& Click this icon to create a currency field. If the form is linked to a database, the
currency field contents for in the form can be adopted from the database.

Pattern Field

& Click this icon to create a masked field. Masked fields consist of an input mask
and a character mask. The input mask determines which user data can be
entered, The character mask determines the state of the masked field when
loading the form,
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The Help feature in OpenOffice.org is very intuitive. It covers features
and the application itself in great detail, and assists by having a
plentiful supply of hyperlinks — so it's easy to go around within the

Help itself.

Help is non-intrusive - that is it's not an annoying paper-clip! If there's
a change made, it pop's up, and it disappears automatically, leaving

the user, hassle-free.

Appears at the
bottom of the
screen showing
a change has
been made




Setting up OpenOffice.org

. quls -> Optlons

Optioi

Enter
relevant
user data
(in this
dialog)

[B OpenOffice.ors

General
tw-  Memory
View
Print
External Programs

Data Sources

Address
Company
First/Last name/lInitials
Streat
Gity/State/Zip
Country/Region
TitlefPosition
Tel. (Home/Work)

Fax / E-mall

- Openoffice.org - User Data

[Calin

[Charles

http:/fwww. bytebot.net/

[eyte@aeon.com.my

= 1

Cancel

Help

mEEEn Copyright © 2003-2004, Colin Charles. Released under a Creative Commons License.
_ http://creativecommons.org/licenses/by-nc-sa/1.0/

The first option allows you to edit the User Data -

customize your version of OpenOffice.org.
You can also change the views, the default fonts used for document
creation, settings for font replacement, auto-saving, printing settings
and many more.
There's individual controls for the applications, however, for examples
in this section, we will be reviewing the options that have an effect on
all the components of OpenOffice.org.
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input information to



Some Setup Features

* Font Substitution

- OpenOffice.org -> Font Replacement
* Turning on AutoSave

- Load/Save -> General
* Setting Undos & Memory Use

- OpenOffice.org -> Memory
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Font Substitution

Font Substitution is handy because when working in an environment
where there are many operating systems, there's also a chance that
there are many different fonts to work with.

Once at the Font Replacement setting dialog, tick Apply Replacement
Table. Under the Change column, for example, change “Times New
Roman” to “Times” (former on Windows, but latter exists on Linux).
You now have the option of selecting Always or Screen only — Always
affects the print-out as well.

AutoSave

Under Save, tick “AutoSave every” and enter some time in minutes.
You have the option of always creating a backup copy, or even
prompting if you should save (where a pop-up will appear at a stated
time).

Under “Always save as” you have the option of saving files (by
default) as a Microsoft Office based file. This can help forgetful staff,
as document exchange with others sometimes needs to be in RTF's
or something Microsoft related.

Undos & Memory Use

Number of undo steps is set at 20 by default - can be increased if
need be

Tweaking the caches if you have the ability can improve performance
of the software.



Pasting Data - Controls

* Content & Formatting can be handled
by “Paste Specia'" Click & hold to get the

e pull-down menu

e Edit -> Paste Special [El % ¢ +Ea &

OpenCffice.org 1.1.0 Presentation

e Paste icon on toolbar : Dawnatoms

GDI metafile

I Bitmap \

» Options dependent on what's in  Jigns of what
item in memory

memory can be pasted as.
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Exercise: Cut & Paste in Linux

* Surf the Internet, or open up your e-mail and copy your text from the
web-browser into OpenOffice.org. This can differ, sometimes
requiring an intermediary application depending on the window
manager you are running.

* Keep in mind that regular cut & paste exists, and the keyboard short-
cuts you're familiar with (Ctrl4+C and Ctrl+V) are similar.

* Another thing you've learnt is that some toolbar items have a little
triangle near them - this means there are other pul-down options.
One example is the Paste toolbar item, which allows you to pull-down
and get Paste Special options.



The Menus & Interface

* Displayed toolbars can be customized

- Tools -> Configure -> Toolbars. Click
Customize.

- Icons may be dragged & dropped onto the
function bar

e The Status bar at the bottom of the
screen can also be customized

- Tools -> Configure -> Status Bar
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The Toolbars & an Exercise

Don't want to view an icon? Right-click it, click Visible Buttons, and un-
tick the icon, that you don't wish to see on the function bar.

Task: Place the Save As button on the function bar, next to the Save
icon. Follow the instructions above.

An alternative method of solving the task is to right-click on the
function bar, and select Customize.

The Status Bar & an Exercise

Looking at the bottom, it shows you relevant information and status
about the current open document. You can add more useful items,
depending on what you think is relevant.

Tip: If the OO0 window isn't fully maximized, you may not be able to
garner the full use of the Status Bar.

Task: Add the current time to the Status Bar.



Dealing with other

applications
* File -> AutoPilot -> Document Converter

@ Document Converter ®
& &

This AutoPilot converts decuments in the old StarOffice format and Microsoft Office
documents to the new OpenOffice.org XML format.

Select the document type for conversion:
" StarOffice

Convert from thesV‘ - =

platforms, to r r
OpenOffice.org ~ ——a € Merosoft Office

documents. I™ Word documents T ——

[~ PowerPoint documents

Please note that when converting Microsoft documents any attached VBA macros lose their
functionality.

¥ Create log file

Cancel Help

EREEEEEEn Copyright © 2003-2004, Colin Charles. Released under a Creative Commons License. Page 15
http://creativecommons.org/licenses/by-nc-sa/1.0/

The Document Converter allows for batch conversions, which makes
transition to OpenOffice.org file formats much simpler.

It should be noted that OpenOffice.org is very compatible with other
applications out there — Writer handles MS Word .doc's as well as .
rtf's very well; Calc does MS Excel, .csv (comma separated values),
dBASE files, and it reads Lotus 1-2-3. Impress works with MS
PowerPoint, and Draw can edit Impress files (as well as StarDraw).
OpenOffice.org, using the OASIS XML format, means it's 100%
compatible with StarOffice file formats as well.

OpenOffice.org also supports other XML-based file formats and can
export to several formats that are suitable for PDA's. Tools -> XML
Fitter Settings for more on this.



Printing

Properties of the
printer are

* Printer Administration — spadmin changed here
* Linux printer should already be set-up

Printer Administration ‘
000 can print to PDF's Installed printers
as well - this is in —_—
addition to Exporting to
a PDF file.
Add another

printer that OOo >
can access
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Printing to PDF's require the Ghostscript drivers, which most Linux
systems come with. This is also standard with Mac OS X (available via
the fink package - apt-get install ghostscript), however Windows
users will need to get a freeware package like PDF Creator, or
purchase the Adobe Distiller.

The Properties option allows the changing of paper size (defaults to
Letter, most outside the USA will prefer it to be A4), permanent page
orientation, printer resolution, and even font replacement.

The “spadmin” utility runs alongside an already configured printer —
so, it is expected that you utilise something like CUPS to configure
your printer. Each distribution of Linux comes with its own way of
doing it; the Red Hat printtool is available on most distributions and is
very friendly.

Exercise

Add a new printer, and configure it for OpenOffice.org usage.



Creating PDF Documents

* File -> Export as PDF ¥ BE
* Options dialog: s por Drecy s POF|

sl [Print optimized — good for
Pages c output to a printer. Press
= optimized garners the
" Range Cancel largest file sizes, as the
 Selection graphics are uncompressed.
. Help Screen optimized is suitable
ompression : s
" Sgreen optimized (smallest file size) for pI'l-IltlIlg, however .
e N graphics and fonts won't
LT eIl look as rich as they should
& Press optimized be
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Adobe Portable Document Format (PDF) documents are a handy way
of distributing documents that you do not want edited. They also look
professional, as they keep their form — they are font independent (on
the system), so documents always look crisp and clear.

Printing to PDF's is allowed as well, instead of using the Export
options that OpenOffice.org has built-in. This as stated earlier, is done
with the help of Ghostscript.

File -> Print, and with the name of the printer, set it to “PDF
Converter”. A file is then created in your home directory.

Why would you do this? Because you have more control - in terms of
presentations, you are able to print slides & notes, or just notes only,
something you can't do with the regular export (which will just print
slides).

What if the “PDF Converter” is not a selectable printer? Add it!
Instead of adding a new printer, choose the option that says
“Connect a PDF converter”, and follow the on-screen instructions.



Thank You!

Colin Charles
byte@aeon.com.my
http://www.bytebot.net/
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