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GETTING STARTED

In  order to start using your  system you will  usually  have to
perform what  is  known  as a user login.   This  procedure is
necessary to identify  yourself to the system.  The system allows
multiple users to use it  concurrently and so it  has to be able to
identify a user in order to grant them the necessary privileges and
rights to  use the system and applications.  Each user upon
successful login will  be assigned to his home directory (folder).

Some systems may have been set up so that upon power-on, a
default user is logged in automatically.  If  this is so, then you will
not be presented with a login screen or prompt as described in the
section below.  You may skip on to the section entitled “Basic
Navigation using the Mouse on the Desktop”.

Note:
There  is  a special  user  called  the  root  or  superuser   (this  user   is
usually   created   during   the   system   installat ion)   which   has
unlimited  access and  rights  to  all   the  system files  and  resources.
You   only   need   to   login   as   root   if   certain   system   level
administrative   tasks   are   to   be   carried   out.   Otherwise   there   is
usually  no  need   for  a  normal  user   to   login  as   root.    This   is   to
prevent   accidentally   damaging   the   system   by   deleting   or
modifying  important  system files.

LOGGING IN

Depending on how you have set up your system, you will  either
have a graphical login screen or a text-based login prompt for you
to perform the login process.

Fig.  Graphical  login  screen

Fig   Text­ based login  prompt

To login, enter the username followed by the ENTER key and
when the password prompt appears, enter the password followed
by the ENTER key.

STARTING THE GRAPHICAL DESKTOP

If  you  have logged in  from  the graphical  login  screen, the
graphical desktop will  be started automatically  for you.  If  you
have used the text-based screen login, you will  have to start the
graphical desktop manually  by entering the command startx
followed by the ENTER key.

Fig  Starting  the graphical  desktop

BASIC NAVIGATION USING THE MOUSE ON THE

DESKTOP

Proper usage of  the mouse is  essential  in  order  to  have a
rewarding and productive experience on the graphical desktop.
Most Linux  graphical desktops are designed for  use with  a 3-
button mouse. If  you  are using a two-button mouse, during
installation, it should have been configured to emulate the middle-
button  of  a  3-button  mouse  by  pressing  both  buttons
simultaneously.

To click  on a mouse the left  button is depressed.  (A  mouse
configured for a left-handed user will  will  need to have its right
button depressed.)  The right (or  left  button for  a left-handed
mouse) and middle buttons are usually used to invoke special or
specific  features of  the GUI  and instructions to do so will  be
explicitly given.

To “select” an item means clicking it once with the mouse.

The term “drag and drop” means that you will  have to click on an
item and while continuing to hold the mouse button down, drag
the item to another place and on reaching its destination drop it by
releasing the mouse button.

MAIN COMPONENTS OF THE DESKTOP

The figure below shows a typical view of  the graphical Linux
desktop.

Fig.  A  typical   Linux  desktop
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localhost login:

[anita@localhost anita]$ startx



There are 3 main components on the desktop:  the menu system,
the panel, the desktop itself.

THE MENU SYSTEM

The main menu can be accessed by clicking on the Main Menu
button located at the lower left hand corner of the desktop.  On a
Fedora Linux  system the default  Main  Menu button is  a red
fedora (a type of red hat).  Clicking on this will  bring up the menu
system as shown in the figure below.

Fig.  3­5 The  menu  system

From the menu system you can start many of  the applications
installed on your  Linux  system. Note that  the menu system
consists of a main menu panel and sub-menu panels.  Each entry
in the menu system which has an arrow on its right means that it
is  an entry point  to a sub-menu, and there can be sub-menus
within  each sub-menu.   In  this way applications in  the menu
system can be organised and categorised for easy reference and
access.

To access a the sub-menu associated with a menu entry, move the
mouse and rest it  on the menu entry in question and a sub-menu
panel will  appear.
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Fig.  Main  menu  and  sub­menu

Clicking  once on  a  menu  entry  will  cause an  application
associated with it to be launched, i.e. executed.

THE PANEL

The long bar across the bottom of the desktop screen is called the
panel.  The panel contains the main menu icon, the application
launcher icons, a notification area and applets.

Fig.  The  panel

Installed by default are several application launcher icons on the
panel.  Clicking on one of these will  run an application.  

Commonly accessed applications can be added to the panel and
those that are less frequently used can be taken off.

The  notification area holds alert icons so that the user can be
alerted to critical messages.

Applets are small  applications that run on the panel.  These
usually  perform useful  and informative tasks like  setting the
sound level  of  the soundcard, monitoring whether the system
software needs an update, etc.  By default the following applets
are run.

The Workspace Switcher

By default the user has 4 desktop workspace areas to work on.
The workspace switcher represents each workspace as a small

square and shows the applications running in each of them.  To
access a workspace click on the square with the mouse.

The Taskbar

The taskbar applet is located next to the workspace switcher and
shows the titles of all the running applications in a virtual desktop
(a workspace).

THE DESKTOP

The  desktop  itself  contains  icons  which  are  graphical
representations of short-cuts to application launchers, file folders,
files and peripheral devices like floppy disks, CD-ROM  drives
and printers.   Double-clicking  on  an  icon  representing  an
application will  launch or execute the application.  Commonly
used applications and/or files/folders are usually  placed on the
desktop space.

Fig.  The  desktop  space

USING THE WINDOW MANAGER

Fig.  An  application  window  frame

THE TITLEBAR

When an application is started an application window opens and a
frame (see figure above) is placed around the window of  the
application.  The top edge of the frame has a titlebar that contains
the title of the application. 
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Fig.  The  window  titlebar

At the left hand corner of the titlebar is the Window Menu button.
Clicking on this button will  open up the Window Menu. You can
perform operations such as minimise, (un)maximise, roll  up,
move and resize the window from this menu.  At the right edge of
the titlebar there are three buttons which allows you to minimise,
(un)maximise and close the window.

MANIPULATING THE WINDOW

Some basic instructions to manipulate the windowing system is
given here.  More details can be obtained by running the “Help”
application  on  the  Main  Menu.   After  running  the  Help
application choose:

Desktop  => Windows => Manipulating Windows

Focus

In order for a window to receive input from the mouse and the
keyboard it  has to be the window “in  focus”.  Only one window
can have focus at a time.  Windows that are not in focus have
their titlebars greyed-out.  To focus on a window place the mouse
on the titlebar and click on it.  (You can actually click anywhere
within the window, but it  is safer to click  on the titlebar since
there is  no possibility  of  accidentally  clicking  on some item
selection or functionality  of  the application running within  the
window.)   If  the window is not visible you can click  on the
taskbar on the panel at the bottom of the desktop to bring into
focus the window you want.

Maximise  and Minimise

Maximising a window means that the window is expanded to
cover the whole desktop while  minimising it  means that  the
window is taken off  the desktop and it  appears as an icon in the
taskbar on the panel. 

You  can maximise a window  which  has focused from  the
Window Menu or by clicking on the maximise button on the
titlebar.  You can similarly minimise the window.  If  the window
does not have focus bring it  into focus first by clicking on the
taskbar on the panel.

Resize

You can easily resize a window, i.e. change its size, by placing
the mouse at an edge of the window and then drag the window to
the desired size.

Move

To move a window to another place on the desktop, place the
mouse on the titlebar,  and drag the window  to  the desired
location.

Roll  Up  and  Unrol l

To roll  up a window allows you to “roll  up”  the window frame
until  what can be seen of the window is just the the titlebar.  You
can perform this operation from the Window Menu.

To restore the window back to its original shape, select the unroll
option from the Window Menu.

Close

You can close a window which has focused from the Window
Menu or by clicking on the close window button on the titlebar.
If  the window does not have focus bring it  into focus first by
clicking on the taskbar on the panel.

Note:  Closing  the window  will  terminate  your  application.

BASIC DESKTOP CUSTOMISATION

The desktop can be customised to your preferences and tastes in a
variety of ways.  Here we will  explore some basic customisations.
More details can be obtained by running the “Help”  application
on the Main Menu.  After running the Help application choose::

Desktop => Basic Preferences

Desktop  Background

The background image displayed on the desktop can be changed
by running the Background application from the Main Menu (this
is in the Preferences sub-menu).

Main Menu => Preferences => Background

To change the background image, click  on the square marked
“Select picture”.  An image selector dialog is displayed.  Choose
an image from the dialog.   If  you want to choose an image from
another directory,  click  the Browse button.   When you have
chosen an image, click OK. 

Fig.  Selecting a new  background  image

Desktop  Themes

The desktop theme specifies the visual appearance of the panels,
applets, and windows. The desktop theme also may also specify
the appearance of interface items in applications. For example, the
theme affects the appearance of buttons, scrollbars, check boxes,
and so on in the applications.

The theme used by the desktop can be changed by running the
Theme application from the Main Menu (this is in the Preferences
sub-menu).

Main Menu => Preferences=-> Theme
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An theme selector dialog is displayed.  To change the theme,
click on a new theme.  

Fig.  Selecting a new theme

Default  Fonts

The default fonts used to display applications and the desktop
background can be changed by  running the Fonts application
from the Main Menu (this is in the Preferences sub-menu).

Main Menu => Preferences => Fonts

A  selector dialog for  the application, window title, dialog and
terminal  fonts  are displayed.  To  change the font  for  each
category of usage, click on the space listing the font.  

Fig.  Selecting new fonts

Menus  and  Toolbars

The Menus &  Toolbars tool is used to customise the appearance
of menus, menubars, and toolbars.  Again this can be run from the
Preferences sub-menu in the Main Menu.

Main Menu => Preferences => Menus &  Toolbars

Experiment on each of the settings to get the ones preferred.

Fig.  Customising menus and  toolbars

DATE AND TIME

It  is important that the date and time are set correctly  in  your
system.  This will  make it  easier to manage the system resources
and files and also aid in troubleshooting any problems.  To set the
date and time, run the Date &  Time application tool  from the
System Settings sub-menu under the Main Menu.

Main Menu -= System Settings => Date &  Time

A dialog box asking for the root password will  appear if  you are
not logged in as root.  This is because the system date and time
are  important  system parameters  and  so  only  the  system
administrator or root is allowed to do it.  After entering the correct
root  password, you  can change the date using the displayed
calender and the time in  the boxes provided.  Select the Time
Zone tab and check to see that the timezone selected is correct.  If
not,  correct  it  by  selecting  the appropriate timezone region.
Usually  the system uses the local  time, so do not  select the
“System clock uses UTC” checkbox.
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Fig.  Setting  the date and  time

Click on the OK button after all  is done to enable the new date
and time.  You can check for the new date and time by resting
your mouse over the time icon displayed on the panel at the
bottom of the screen.

USING THE DESKTOP

The desktop provides a useful metaphor for a modern office work
environment.  So on the desktop we find that the applications that
we want  to  run  can easily  be started or  launched and the
information and data that we need can easily be located.

Applications that we can run from the desktop are to be found
either from the Main Menu (and sub-menus therein), or as icons
on the panel and the desktop itself.  

To run an application from the Main Menu, open up the menu,
select the application therein and click on the application listed in
the menu bar.

To run an application from the panel, click  once on the icon
representing the application.

To run an application from the desktop itself,  double-click on the
icon representing the application.

Sometimes it is more handy to have the application as an icon on
the panel or desktop where you can launch it  more easily by just
clicking on it,  rather than in the Main Menu, especially  if  it  is
buried deep within several sub-menus.  To achieve this open the
Main Menu and select the application item listed in it  by clicking
with the right  mouse button.  Click  on the selection “Add this
launcher to panel”  and a copy of  the application icon will  be
placed on the panel.  

To make a copy of  this on the desktop, you can drag the icon
from the panel over to the desktop.

To delete  an application icon from the panel right­ click  on it and
select the “Remove from Panel” option.

To delete  an application icon from the desktop, right­ click  on it
and select the “Move to Trash” option.

USING THE FILE MANAGER

One of the most powerful features of a modern computer system
is the ability to store data in a form which can be easily retrieved
and transported or copied across to other computer systems or
media.  Data created and accessed by a user in the computer is
stored in what is called a file .  This concept of an electronic file to
store electronic data mimics the physical world usage of a file to
store data written on paper.  This mimicry is carried further by the
organisation of  these electronic files into  electronic folders or
directories.  Like a physical folder, an electronic folder 
can contain very many files.  A folder may also have sub-folders
or sub-directories.

Note:
Within   this   document   we   shall   be   using   the   terms   folder   and
directory  interchangeably,  unless stated otherwise.

Files and folders can be created, copied, moved (i.e. transferred)
and  deleted.   The  folders  themselves are  organised  in  a
hierarchical manner starting at the root of the file system.  Each
user is given a home directory and upon logging in, the user is
placed in his home directory.  As it is possible for a user to create
and store hundreds and thousands of  files and folders, a file
manager is needed to assist the user to manage and manipulate
these files and the file system on which it resides.

In this section a brief description of the file manager and how to
use it  is given.  For more details you should consult the “Help”
application  on the Main  Menu.   From the Help  application
choose:

Desktop => Nautilus File Manager

To start using the file manager double-click on the home directory
icon on the desktop.  (This may be named “username's Home”
where username is the username of the user currently logged in.)

Fig.  The  file manager

By default, the file manager consists of a side pane and a main
view pane.  At  the top of  the window just under the window
titlebar, are the menu bar and the location bar.
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The view pane displays the files and folders contained in  the
current directory that the user is in. These can be displayed as
icons (default)  or  changed to  display  them as a listing  of
filenames.

The side pane contains an icon that represents the current file or
current folder. The side pane also contains information about the
current file or current folder.   A  hierarchical (tree) view of the
file system on the computer can be obtained from the side pane.
By  navigating through this,  you can access files and folders
outside you home directory (provided of course that you have the
authority to do so).

Fig.  The  side pane with  a tree view  of folders

Accessing  Files  and  Programs

From the view pane of the file  manager, you can open files as
well  as run (launch) executable programs by double-clicking on
the icon representing them.

Creating  New Folders

To create a new folder under the folder you are currently in, move
the mouse to the menu bar at the top (just beneath the titlebar of
the window) and click on File and then click on Create Folder.  A
new folder will  appear on the view pane and you will  have to type
in the name of the new folder.

Copy  Files  and Folders

To copy a file, click on the file in the view pane to select it.  Then
select from the menu bar at the top,

Edit => Copy File 

Next open up the folder in which you want to copy the file to and
then select from the menu bar at the top,

Edit => Paste Files

Another way to copy a file is to right click on the file icon and
then select “Copy File”.  Then navigate to the icon of the folder
where you want the copy to be placed in and then right click on
the folder icon and select “Paste Files into Folder”.

The procedures above can be done with folders too.

To copy more than one file or folder at a time, select multiple
files/folders by holding down the CTRL key while clicking on the
files or folders.

Moving  Fi les  and Folders

Moving a file or folder is different from copying in that a copy of
the file/folder is not made, i.e. only one copy of  the file/folder
exists, and the file/folder is transferred from one folder to another.

To move a file, click  on the file  in  the view pane to select it.
Then select from the menu bar at the top,

Edit => Cut File 

Next open up the folder in which you want to move the file to and
then select from the menu bar at the top,

Edit => Paste Files

Another way of moving a file is to drag and drop the file into the
destination folder.

The procedures above can be done with folders too.

To move more than one file or folder at a time, select multiple
files/folders by holding down the CTRL key while clicking on the
files or folders.

Renaming  Files  and Folders

To rename a file, click on the file in the view pane to select it.
Then select from the menu bar at the top,

Edit => Rename

and then type in the new name.

Alternately you can also right-click  on the file  and then select
“Rename” .

The procedures above can be done with folders too.

Deleting  Fi les  and Folders

To delete a file, click  on the file in the view pane to select it.
Then select from the menu bar at the top,

Edit => Move to Trash 

Alternately you can select the file and then use the DELETE key
on the keyboard to delete the file.  This has the same effect as
above of moving the file to the Trash folder.

It is still  possible to salvage the a deleted file from the Trash.  To
do this double-click on the Trash icon on the desktop to open up
the Trash folder.  Then you can move the file you want to salvage
to the desired folder.  Note that  if  you delete the file from the
Trash then it cannot be recovered anymore.

The procedures above can be done with folders too.

To delete more than one file or folder at a time, select multiple
files/folders by holding down the CTRL key while clicking on the
files or folders.

THE TRASH CAN
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The trash can icon on the desktop contains files and folders which
you have deleted using the file  manager or an application run
from the desktop.  As noted above it  is a special folder in which
in is still  possible to move back the deleted items to another folder
so as to “undelete” them. However over time, the trash folder will
be filled up as many files and folders get deleted through usage.
So it  is a good idea to periodically  empty or delete the items
found in the trash. 

To  empty the trash, right-click  on the trash icon and select
“Empty Trash”.  Otherwise you can open the trash by double-
clicking on it  and then select to delete all  the items in the trash
folder using the file manager functions described above.

LOGGING OUT 

When you have finished working on the system, you will  need to
logout.  To logout, at the Main Menu select:

Main Menu => Logout

and at the dialog window select logout and click OK

Fig.  Logout  dialog window

SHUTTING DOWN THE SYSTEM

When you have finished using the computer and want to power it
off, you will  have to perform a system shutdown.

Note:
It  is  very  important  that  a proper  system shutdown  is  made.   You
should  not  just  turnoff  the power  switch  of  the computer  to  shut  it
down.    Failure   to  observe   this  may  lead  to  system  software  and
data  corruption  and failure.

To shutdown, at the Main Menu, perform a logout.  Then at the
graphical  login  screen select  the “Shut  down”  option  at  the
bottom of the screen.  Sometimes (depending on the login screen
chosen) the Shutdown option is available as a sub-option under
the  Actions option at the bottom of the screen.

Alternatively you may also perform a shut down by performing a
log out operation as described in the previous section but instead
of selecting “Log out”,  select the “Shut  down”  option from the
Logout dialog.
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