{"id":688,"date":"2008-01-04T11:46:29","date_gmt":"2008-01-04T16:46:29","guid":{"rendered":"http:\/\/www.bytebot.net\/blog\/archives\/2008\/01\/04\/zimbra-zcs-50-ga-is-it-really-a-ga-release"},"modified":"2008-01-11T03:37:39","modified_gmt":"2008-01-11T08:37:39","slug":"zimbra-zcs-50-ga-is-it-really-a-ga-release","status":"publish","type":"post","link":"https:\/\/www.bytebot.net\/blog\/archives\/2008\/01\/04\/zimbra-zcs-50-ga-is-it-really-a-ga-release","title":{"rendered":"Zimbra ZCS 5.0 GA &#8211; is it really a GA release?"},"content":{"rendered":"<p>I took the opportunity today evening to get myself upgraded (from 4.5.3_GA_733) to the latest (5.0.0_GA_1869) open source version of Zimbra &#8211; ZCS 5.0 GA. The database migration took about the longest, mainly due to some schema changes. Lots of starts and stops to the database. Its now running MySQL 5.0.45 Community.<\/p>\n<p>What prompted the upgrade? A few days ago, I got a bunch of new packages, and rebooted the server (new kernel). To my dismay, Zimbra started to have issues &#8211; <tt>amavisd<\/tt> wouldn&#8217;t start. This meant that there was a large amount of mail, sitting in the queue, not being delivered. Things you don&#8217;t normally check for, immediately, anyway.<\/p>\n<p>Turns out <a href=\"http:\/\/www.zimbra.com\/forums\/installation\/9682-av-issue-after-upgrading-4-5-5-compress-zlib-not-found.html\">Compress::Zlib was too old<\/a>. Well, not the system provided <tt>Compress::Zlib<\/tt>, but the Zimbra provided <tt>Compress::Zlib<\/tt>. Kind of annoying when there are two packages of software, sitting on your system, right? However, the benefits of having an easy-to-administer and use mail system, somehow I think outstrips all the pain associated.<\/p>\n<p>I found the web interface in ZCS 4.5.3 to be a bit limited, even when logged in as an administrator. There was absolutely no way to restart, failed services. For this, I actually needed to login via SSH, and use <tt>zmcontrol<\/tt>. Running SSH on a non-standard port, and not having your laptop nearby (or remembering the non-standard port) can allow you to have some fun :)<\/p>\n<p>So after fixing ZCS 4.5.3, and realising that it had some gaping holes, I decided to upgrade. The upgrade process went on pretty smoothly, till I saw:<br \/>\n<tt>Updating from 5.0.0_RC3<br \/>\n5 is only avaliable with the XS version at \/opt\/zimbra\/zimbramon\/lib\/IO\/Socket\/SSL.pm line 30<br \/>\nBEGIN failed--compilation aborted at \/opt\/zimbra\/zimbramon\/lib\/IO\/Socket\/SSL.pm line 30, &lt;DBCONFIG&gt; line 21.<br \/>\nCompilation failed in require at \/opt\/zimbra\/zimbramon\/lib\/Net\/LDAP.pm line 970, &lt;DBCONFIG&gt; line 21.<br \/>\n<\/tt><br \/>\nThis has largely got to do with the RHEL4 supplied Perl, as referenced by zimbra bug <a href=\"http:\/\/bugzilla.zimbra.com\/show_bug.cgi?id=22466\">#22466<\/a>. However, it seems that it was fixed in 5.0.0_GA_1809. Problem still seems to be around in 5.0.0_GA_1869. Verified that it existed &#8211; <tt>\/opt\/zimbra\/zimbramon\/lib\/i386-linux-thread-multi\/Scalar\/Util.pm<\/tt> (and was newer than the version on the system). Verified that Zimbra saw it too &#8211; check out <tt>.bashrc<\/tt> in <tt>\/opt\/zimbra<\/tt> (the home directory for the zimbra user) for the various PATHs that Zimbra sees\/requires. However, I was running this install, not as the zimbra user, so the Perl PATHs had to be specified.<\/p>\n<p>Specifying the Perl PATH, also didn&#8217;t help. The forums mentioned just installing from <tt>cpan<\/tt>, <tt>Scalar::Util<\/tt> and letting the install progress. It still failed.<\/p>\n<p>I thought I&#8217;d try a <strong>clean<\/strong> install. By golly, it failed on RHEL4. An upgrade of a clean install from ZCS 4.5.10 also failed. I&#8217;m almost convinced that Zimbra spent very little time QA&#8217;ing ZCS on RHEL4. Sure, RHEL5 probably works a charm, but the drive of enterprise software is not upgrading the OS too often. This is where I can so see, FreeBSD succeeding &#8211; pity there isn&#8217;t an official Zimbra\/FreeBSD port.<\/p>\n<p>For fun reading, check out their forums: <a href=\"http:\/\/www.zimbra.com\/forums\/administrators\/13746-solved-big-fubar-5-foss-ga-upgrade.html\">[SOLVED] Big Fubar on 5 FOSS GA Upgrade<\/a> (how was it solved?), <a href=\"http:\/\/www.zimbra.com\/forums\/installation\/13899-upgrade-4-5-7-5-0-ga-failed.html#post70959\">Upgrade 4.5.7 -&gt; 5.0 GA Failed<\/a>, <a href=\"http:\/\/www.zimbra.com\/forums\/installation\/13811-centos4-upgrade-5-0-errors.html#post71102\">centos4 upgrade to 5.0 errors<\/a>. I&#8217;m sure this magical list can go on and on. All purported <em>solutions<\/em> generally, do not work.<\/p>\n<p>Moral of the story? Even with backups, don&#8217;t try upgrading Zimbra on a production box. Be prepared to cry, a lot.<\/p>\n<p>Technorati Tags: <a href=\"http:\/\/technorati.com\/tag\/zimbra\" class=\"performancingtags\" rel=\"tag\">zimbra<\/a>, <a href=\"http:\/\/technorati.com\/tag\/zimbra%20collaboration%20suite\" class=\"performancingtags\" rel=\"tag\">zimbra collaboration suite<\/a>, <a href=\"http:\/\/technorati.com\/tag\/zcs\" class=\"performancingtags\" rel=\"tag\">zcs<\/a>, <a href=\"http:\/\/technorati.com\/tag\/zcs5\" class=\"performancingtags\" rel=\"tag\">zcs5<\/a>, <a href=\"http:\/\/technorati.com\/tag\/qa\" class=\"performancingtags\" rel=\"tag\">qa<\/a>, <a href=\"http:\/\/technorati.com\/tag\/ga\" class=\"performancingtags\" rel=\"tag\">ga<\/a>, <a href=\"http:\/\/technorati.com\/tag\/upgrades\" class=\"performancingtags\" rel=\"tag\">upgrades<\/a><\/p>\n","protected":false},"excerpt":{"rendered":"<p>I took the opportunity today evening to get myself upgraded (from 4.5.3_GA_733) to the latest (5.0.0_GA_1869) open source version of Zimbra &#8211; ZCS 5.0 GA. The database migration took about the longest, mainly due to some schema changes. Lots of starts and stops to the database. Its now running MySQL 5.0.45 Community. What prompted the [&hellip;]<\/p>\n","protected":false},"author":1,"featured_media":0,"comment_status":"open","ping_status":"open","sticky":false,"template":"","format":"standard","meta":{"_jetpack_newsletter_access":"","_jetpack_dont_email_post_to_subs":false,"_jetpack_newsletter_tier_id":0,"_jetpack_memberships_contains_paywalled_content":false,"_jetpack_feature_clip_id":0,"_jetpack_memberships_contains_paid_content":false,"footnotes":"","jetpack_publicize_message":"","jetpack_publicize_feature_enabled":true,"jetpack_social_post_already_shared":false,"jetpack_social_options":{"image_generator_settings":{"template":"highway","default_image_id":0,"font":"","enabled":false},"version":2},"jetpack_post_was_ever_published":false},"categories":[1],"tags":[],"class_list":["post-688","post","type-post","status-publish","format-standard","hentry","category-general"],"jetpack_publicize_connections":[],"jetpack_shortlink":"https:\/\/wp.me\/p4vJD-b6","jetpack_sharing_enabled":true,"jetpack-related-posts":[],"amp_enabled":true,"jetpack_featured_media_url":"","_links":{"self":[{"href":"https:\/\/www.bytebot.net\/blog\/wp-json\/wp\/v2\/posts\/688","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/www.bytebot.net\/blog\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/www.bytebot.net\/blog\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/www.bytebot.net\/blog\/wp-json\/wp\/v2\/users\/1"}],"replies":[{"embeddable":true,"href":"https:\/\/www.bytebot.net\/blog\/wp-json\/wp\/v2\/comments?post=688"}],"version-history":[{"count":0,"href":"https:\/\/www.bytebot.net\/blog\/wp-json\/wp\/v2\/posts\/688\/revisions"}],"wp:attachment":[{"href":"https:\/\/www.bytebot.net\/blog\/wp-json\/wp\/v2\/media?parent=688"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"https:\/\/www.bytebot.net\/blog\/wp-json\/wp\/v2\/categories?post=688"},{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/www.bytebot.net\/blog\/wp-json\/wp\/v2\/tags?post=688"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}